Backing Up
To start this subject we need to ask ourselves how valuable do we consider the data that is stored on the hard
disc drive of the computer we use, whether it is a RiscPC, Iyonix, PC or Apple.
If a disaster were to strike, it could be that some or all of the data on the computer hard disc drive is not
accessible.
It could be that the data loss is trivial - just an email or a document may have been deleted in error. Look in the
deleted files folder or the recycle bin; this may allow the data to be retrieved.
If the hard drive is a few years old, there is nothing stopping the entire drive either failing to spin up, or failing
whilst in use, thus taking with it all of the information stored on its glittery platters. A chilling inevitable fact is
that this component part of the PC is going to fail at some time and when it does, it may take all of the data
with it.
First question: has the computer user done anything to make the outcome of this scenario easy to manage?
If no backups exist the resulting exercise to recover the data could be quite expensive. However, if a strategy
for backing up is in place, there should be few problems in retrieving the data from the backup device/media.
Second question: what next?
Check out the soundness of the hard disc drive; do a full format. This will map out any errors on the drive; it
will not overwrite the data. However it may make the disc readable by the operating system. If the disc is
recognised by the operating system then at this stage you could use a program like GetDataBack for FAT or
GetDataBack for NTFS (from http://www.runtime.org) to recover any data that is on the drive. I have used this
program on a number of occasions on computers used by people who for whatever reason did not back up their
data and have subsequently had a computer/disc crash.
At this point consider purchasing a new hard disc drive, with the re-installation of the operating system.
Relative to the value of the data stored on the disc they are inexpensive; the users have to decide on the best
strategy for themselves.
Backing up data from the computer is perhaps not the most exciting of computer activities; it is still something
that should be carried out on a regular basis. A system backup is a vital lifeline that safeguards the information
stored on the computer. In most cases, the data is worth far more than the computer it is stored on. In other
cases, irreplaceable items such as family photographs, music, video tracks, work sheets and projects could be
lost.
Some good news is that backing up can be a simple job. It can be scheduled to take place at a set time every
week or every day. After the first backup has taken place it is something that takes place very quickly even
while working on the computer. If the data is considered to be valuable it is a job not to be delayed - back up
today.
A backup program is provided with Windows XP; in the Pro version it is located here: All Programs →
Accessories → System Tools → Backup. In the XP Home version it will need to be installed from the
Windows installation disc; instructions below.
Manually install the backup utility in Windows XP home
Insert the XP Home installation CD-ROM into the CD-ROM drive, and then navigate to the
\ValueAdd\MSFT\NTBACKUP folder.
Double-click on the Ntbackup.msi file to start the Backup installation wizard. Follow the on-screen prompts to
install the wizard, and once it is complete, access the Backup utility by clicking the Start button and choosing
All Programs → Accessories → System Tools → Backup.
See the screenshot below which illustrates where choices can be made on the folders to backup.
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The dialogue box shown below is presented to the user. The next stage is to click the Start Backup button and
the backup will be created on the destination drive.
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Where should you backup to? A convenient option is to use a separate hard drive as a secondary drive in the
computer. This is easy to achieve, very fast and these days is not too expensive. The downside is that the data
is still physically located in the same PC and therefore the data is still at risk if the PC is stolen. Other options
include backing up to a networked system involving another computer or to an external USB / Firewire
connected box containing a hard disc drive or to optical discs (CD / DVD).
Preparing to Back Up
Before starting to back up data you need to know what to keep in the first place. If a backup of the entire hard
disc is made which includes the operating system files, a full restore from this backup will not function, the
reason being that, whilst Windows is running, there are many files, applications and processes that are in use
and cannot be backed up. A workaround to this scenario is to use the appropriate software. See the section
below which mentions Symantec Norton Ghost.
What to back Up
Desktop Display
If the desktop has been customised, back this up too. Go into the Display Properties, click the Themes tab,
select My Current Theme or Windows XP (modified) click the Save As… button. Save this Theme file with
other items being saved.
Documents and Settings
It is worth backing up the entire Document and Settings folders, therefore all of the files listed below will be
backed up. This will ensure desktops, documents, program settings and more are saved. Some of the files
indicated below are hidden by default. To see them, open an Explorer window, select Tools → Folder Options
→ View; then select the radio button against “Show hidden files and folders”. Individual paths are listed
below:
Desktop files saved when backing up the Documents and Settings folder
Desktop: C:\Documents and Settings\USER NAME\Desktop
My Documents: C:\Documents and Settings\USER NAME \My Documents
My Documents may contain My Pictures, My Music etc.
Outlook: C:\Documents and Settings\USER NAME\Local Settings\Application Data\Microsoft\Outlook
Outlook Express: C:\Documents and Settings\USER NAME\Local Settings\Application Data\Identities
Address book: C:\Documents and Settings\USER NAME\Application Data\Microsoft\Address Book
Favourites: C:\Documents and Settings\USER NAME\Favorites
Templates: C:\Documents and Settings\USER NAME\Application Data\Microsoft\Templates
The My Documents Folder
By default, the My Documents folder is created in the Documents and Settings folder and that is found in the
root of the base Windows XP partition, typically the C drive, unless it has had its location changed to be on a
different drive to drive C. Here, is found a folder for each user account, along with additional ones called
Administrator and All Users; these two can largely be ignored.
As illustrated above, backing up the user account folders will protect an enormous amount of information.
Specifically, if Microsoft’s own Office products are used, it will save emails, email settings, favourites,
desktop items - the majority of program settings and documents that makes a Windows XP installation unique.
However, it is unlikely that all the software used is from Microsoft. In those cases, particularly with opensource software, program settings and program data files, such as actual emails, could be stored alongside the
program in its program folder. This means digging around the Program Files folder to check specifically which
programs and data files need to be backed up. It may be an easy task to back up the entire programs folder.
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There are a number of other items that it is best to back up and put in a safe place. These are the software
applications - always keep the installation discs in a safe place and even better, create a backup or a copy of the
installation files on a separate hard disc or optical disc (CD/DVD). The same procedure applies for system
drivers. If Windows XP needs re-installing, having a collection of drivers to hand can save hours of
downloading and hunting around on-line for the correct driver. The simplest solution is to create an application
and driver folder separately on the backup system and place copies of drivers in it.
Reactivation
Constant reinstallations can make life a misery due to the Windows XP activation process. Here is a way to
back up these activation files.
When a copy of Windows XP is activated, it creates two files called WPA.DBL and WPA.BAK in the
C:\Windows\system32 folder. These files contain the encrypted identification code that uniquely identifies the
PC with the Windows XP licence code.
If a reinstall of Windows XP is necessary, these files can be copied back, fooling Windows XP into thinking it
has been activated again, as long as the hardware configuration has not changed. Copy these two files to a
separate hard disc or optical disc (CD/DVD) as mentioned above.
Reinstall XP as normal and restart in Safe mode by pressing [F8] immediately after booting. Select Safe mode
from the Advanced Start menu. This starts Windows with a minimal set of generic drivers, and does not
execute the start-up programs. Launch Windows Explorer, go to C:\Windows\System32 and rename the
WPA.DBL and WPA.BAK files that currently exist to WPA.NONACTIVATED and
WPABAK.NONACTIVATED. Copy the two original activation files to the same location, then restart the
computer normally and Windows XP will be activated.
Some Useful Tools that Can Be Used
Microsoft Backup is free and comes with Windows XP, and it works. It may lack some of the more advanced
features in other programs; nevertheless it is a good starting point.
Another backup application is EZBack-it-up
http://www.rdcomp.net/download.php
It is a free download.
Handy Recovery
http://www.handyrecovery.com
This is a useful application if you are unlucky enough to lose a file that has not been backed up, which is
always a possibility, this undelete tool could be a lifesaver.
Get Data Back
http://www.runtime.org/gdb.htm
This program can recover data from a disc not recognised by Windows XP.
When it comes to writing backup files to optical disc, there may be a need to split them into CD or DVD-sized
chunks. KFKutter a free utility can do just that.
http://www.snapfiles.com/get/kfkutter.html
Symantic Norton Ghost
Another useful piece of software that could be considered is Symantec Norton Ghost. The program has some
good features. It can make an exact copy (clone) of the hard disk, so it is a natural tool for system recovery,
duplicating the C drive in the desktop PC or moving everything from an old PC to a new system. It can store
drive images on just about any kind of media, including another hard drive in the computer, a network server,
an external USB or FireWire hard drive, or various CD-RW and DVD-RW/+RW discs. Current versions of the
program add Linux and NTFS support, and largely eliminate the need for a boot disk and lets two PCs be
joined via a USB, parallel, or network connection and then clone one to the other.
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The latest version Norton Ghost 10.0 supports
•

“Hot imaging” - allows the creation of backup images without restarting Windows. *

•

Incremental backup updates saving time and disk space.*

•

Scheduled backups automatically keep the backup image up to date.*

*Not available in Ghost 2003, a previous version.
Although Ghost supports both NTFS and external USB drives, it cannot do so at the same time. The DOS
driver that finds and mounts the external drive cannot read NTFS, even though once the computer has booted
to use Ghost, it can see NTFS drives. Therefore, if the plan is to create Ghost images that involve external USB
hard drives, they should be formatted as FAT32.
Support for older Windows versions – Norton Ghost 10 does not run on Windows 9x, Windows Me, or
Windows NT Workstation 4.0. If you have one of these operating systems, you should use Norton Ghost 2003,
which is also included in the retail version of Norton Ghost. Programs from other software suppliers include
Acronis Disk Director Suite, Paragon Partition Manager and R-tools Technology, R-Drive Image.
Outlook Back Up
If you only need to have a backup of the information used by Outlook, Microsoft have a utility called Personal
Folders Backup (pfbackup.exe) a 160KB download from their site.
Backing up the Microsoft Outlook information is quicker and easier with the Personal Folders Backup feature.
Personal Folders Backup creates backup copies of Outlook 2000 and later versions of the .PST data files at
regular intervals, thus making it easier to keep the entire Outlook folders safely backed up. With Personal
Folders Backup, it is possible to choose which of the .PST files to select, and how often to back them up.
Each .PST file contains all of the Outlook folders, including the Inbox, Calendar, and Contacts.
There may be a single .PST file (usually called "Internet Folders" or "Personal Folders" in the Folder List).
There may also be an additional .PST file that is used for archiving ("Archiving Folders"). Personal Folders
Backup can back up any or all of these .PST files for any of the profiles created on the computer.
Something to be Aware of …
If a re-installation of the Windows set up has to be carried out, incidentally this is a recommendation that
should be carried perhaps once a year to purge all of the garbage that is associated with the installing and
uninstalling of programs over time.
It may be found that if a backup of the Documents and Settings folder has been made to another device with
the profile that was created during the initial installation it will probably be inaccessible. The following error
message may be seen, where Folder is the name of the folder that cannot be opened: “Folder is not accessible.
Access is denied”.
Cause
This issue may occur if the folder that cannot be opened was created on an NTFS file system disc by using a
previous installation of Windows, and then re-installing Windows XP. This issue may occur although the
correct user name and password has been entered. It occurs because the security ID for the user has changed.
Although the same user name and password has been used, the Security ID (SID) no longer matches the
Security ID of the folder when it was previously created.
For example, although the same user name and password is used, it may not be possible to have permission to
open the folder after completing any of the following steps:
1. Before installing Windows XP Professional, the actual location, or target location, of the My
Documents folder on another volume is changed.
2. The primary partition is formatted.
3. Windows XP Professional is installed.
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Resolution
To resolve this issue, Simple File Sharing must be turned off and then ownership of the folder can be taken:
1. Turn off Simple File Sharing:
1. Click Start, and then click My Computer.
2. On the Tools menu, click Folder Options, and then click the View tab.
3. Under Advanced Settings, click to clear the Use simple file sharing (Recommended) check
box, and then click OK.
2. Right-click the folder that it is wanted to take ownership of, and then click Properties.
3. Click the Security tab, and then click OK on the Security message, if one appears.
4. Click Advanced, and then click the Owner tab.
5. In the Name list, click the user name, Administrator if logged in as Administrator, or click the
Administrators group. If you require taking ownership of the contents of that folder, click to select the
Replace owner on sub-containers and objects check box.
6. Click OK. The following error message may be received, where Folder is the name of the folder that it
is required to take ownership of: “You do not have permission to read the contents of directory Folder.
Do you want to replace the directory permissions with permissions granting you Full Control? All
permissions will be replaced if you press Yes”.
7. Click Yes.
8. Click OK, and then reapply the permissions and security settings that you want for the folder and the
folder contents.
Microsoft site reference: http://support.microsoft.com/default.aspx?kbid=810881

Developments and My Personal Backup Procedure
There have been some recent changes in the media types that are almost available (September 2006).
The available types of backup media remains similar except we now have on the horizon Blu-ray and
HD DVD. These two formats and their supporters are fighting for supremacy as the next-generation videodisc
and data storage format: HD-DVD (developed by Toshiba and NEC) and Blu-ray (developed by Sony). The
DVD Forum supports HD-DVD, but this does not mean that HD-DVD has won the format war.
http://www.hddvd.org/hddvd/
These disc formats have been developed to enable recording, rewriting and playback of high-definition video
(HD), as well as storing large amounts of data. The format offers more than five times the storage capacity of
traditional DVDs and Blu-ray discs can hold up to 25GB on a single-layer disc and 50GB on a dual-layer disc.
http://www.blu-ray.com
The format HD DVD can store 15 GB on a single layer and 30GB on a dual layer disc.
Also in the interim period there have been developments in hard disc technology. We now have SATA discs as
well as the original PATA standard that is still used today in many desktop and laptop computers. SATA is
translated into Serial Advanced Technology Attachment and PATA is translated into Parallel Advanced
Technology Attachment. See this website for a comparison:
http://www.directron.com/patasata.html
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Where do I stand as a home user?
I have not made any extra investment in optical reading/writing above the DVD readers and writers in the two
desktop computers that I use. I have made extra investment in magnetic disc storage, In that I have several high
capacity hard disc drives each contained in a trusty Sarotech USB2 connected housings.
As may be interpreted from the above, I do not store any of my data on optical discs. In the past I have had a
number of those discs that have for one reason or another became unreadable.
Where is my primary data stored?
I made a conscious decision a few years ago to move all of my data off the “C” drive. The My Documents
folder resides on the “D” drive and I have separated out the files used by Outlook to a separate folder on the
“D” drive too. Look here for some useful information:
http://support.microsoft.com/?kbid=287070
on how to manage .PST data files used in Outlook. If you would like to re-locate your Outlook .PST files on a
drive other than drive “C” look at this data sheet:
http://office.microsoft.com/en-us/assistance/HA011124801033.aspx.
Also available from Microsoft is the Outlook 2003 Add-in: Personal Folders Backup Utility. This can be
downloaded from:
http://www.microsoft.com/downloads/details.aspx?FamilyId=8B081F3A-B7D0-4B16-B8AF5A6322F4FD01&displaylang=en
This makes backup copies of the .PST files in Outlook 2000 and later versions, at regular intervals, making it
easy to keep your entire Outlook folders safely backed up.

What software do I use before carrying out a full backup?
I use one or both of CCleaner
http://www.ccleaner.com/
and CleanUp!
http://www.stevengould.org/software/cleanup/
You may ask why.
Both programs delete browser cache, browser history, cookies, bookmarks and favourites; recycle bin contents,
recent documents, temporary files, temporary internet files and log files. Deletion of these is optional and
disabled by default. I do not want my backups to contain those files as they do not carry any meaningful data
and would bloat the backup.
CCleaner also has the addition of a registry cleaner with advanced features to remove unused and old entries,
including file extensions, activeX controls, ClassIDs, ProgIDs, uninstallers, shared DLLs, unwanted fonts,
unwanted help files, obsolete software, application paths, icons , clearing the MUI cache and invalid shortcuts
etc. All of the settings are configurable.
What do I regularly backup?
Everyday I backup the Outlook data files; other data which is generally contained in the My Documents folder
at least once a week. If I am working on a major project I save it and back that up at regular intervals whilst
working on it. I would have choked just a little bit if I had had to recreate a multi-layered Photoshop image
which was used to create the graphic on a roller banner 2 metres by 0.8 metres, 1.6 GB in size.
A small comment should be made about some actions that need to be taken before backing up any data files.
One program that runs in the background on my main desktop computer, namely Copernic Desktop Search,
“holds” onto Outlook’s data files. Therefore before initialising a backup of these files I have to quit this
program, otherwise the report in the log file from EZBackitup states that “The process cannot access the file
because it is being used by another process”.
Barry Thompson – September 2006

-7-

Backing Up
What backup software do I regularly use?
My backup routine is handled very well by EZBackitup from:
http://www.rdcomp.net
I know other people successfully use Allway Sync from:
http://allwaysync.com/
Both are free programs for home use. One or two persons in my circle of home computer users use Dantz
Retrospect Express which is provided with Maxtor’s “One Touch” backup system.
I recently read an interesting short thesis “Storing Your Digital Images” from Vincent Bockaert author of 123
of Digital Imaging. It is well worth a look:
http://www.dpreview.com/learn/?/General/Storing_Your_Digital_Images_01.htm
Summary
When you add up the time and effort that you have spent creating those digital photographs, documents
including worksheets, letters, spreadsheets and e-mails, ask yourself this question. If they become unavailable
to me in the next few minutes, hours or days, what will I do about it? First cry and swear!! Then post a call for
help on various support mailing lists.
Tip: if you have not already done so, invest in some device to store your data off the computer’s “C” drive.
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